1. Shotbow is now 1.8 compatible! It is recommended you play on Minecraft version 1.7.5 for the best experience, but you may join with any 1.7 or 1.8 client.

Shot bow games down...

Discussion in 'The Network' started by hengsty, May 9, 2013.

Shot bow games down...
  1. hengsty Regular Member

    XP:
    8,052xp
    Hey just wondering why all the shotbow games servers are down, every sign at spawn lists them as being on standby and its been like this for a few hours now.. Just was curious about what's going on?