1. Shotbow is now 1.8 compatible! It is recommended you play on Minecraft version 1.7.5 for the best experience, but you may join with any 1.7 or 1.8 client.

Shotbow.net! US-

Discussion in 'Bug Reports & Technical Support' started by Domleeku, Apr 28, 2013.

Shotbow.net! US-
  1. Domleeku Regular Member

    XP:
    5,172xp
    Can anyone connect to the US shotbow network? I cant for some reason, I get timed out and it says "null"
  2. Ju1cY_0n3 Emerald

    XP:
    4,759xp
    It looks like the US servers are still undergoing maintenance. Just hold on for a few hours and it should be fixed. As for the 'null' thing, that usually signifies database maintenance, as that is when I get it all the time.